6. Write a program to accept a number and check whether the number is a perfect square
or not
Sample Input: 49
Sample Output: A perfect square (java program)
Answers
Answered by
2
package com.company;
/* Write a program to accept a number and check whether the number is a perfect square or not.
Sample Input=49
Sample Output= A perfect square.
*/
import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner sc = new Scanner (System.in);
System.out.println("Enter a Number:");
double n = sc.nextDouble();
double n2 = Math.sqrt(n);
if (n2%1==0) {
System.out.println("The entered number is a perfect square");
}
else {
System.out.println("The entered number is not a perfect square");
}
}
}
Similar questions
Sociology,
4 months ago
Environmental Sciences,
4 months ago
English,
4 months ago
Accountancy,
9 months ago
English,
9 months ago
Math,
1 year ago
History,
1 year ago