Computer Science, asked by saumya61284, 3 months ago

9. Write a program to accept Principal, Rate and Time. Calculate and display the interest accumulated for the first year, second year and the third year compound annually
Sample Input: Principal = 5,000, Rate =10% per annum, Time=3years
Sample Output: Interest for the first year: 500
Interest for the second year: 550
Interest for the third year: 605​

Answers

Answered by kamalrajatjoshi94
5

Program:-

import java.io.*;

public class Interest

{

public static void main(String args[]) throws IOException

{

InputStreamReader read = new InputStreamReader(System.in);

BufferedReader in = new BufferedReader(read);

System.out.print("Enter Principal: ");

double p=Double.parseDouble(in.readLine());

System.out.print("Enter Rate: ");

double r= Double.parseDouble(in.readLine());

System.out.print("Enter Time: ");

int t = Integer.parseInt(in.readLine());

double i1 = p * r * 1 / 100.0;

double amt = p + i1;

System.out.println("Interest for the first year: " + i1);

double i2 = amt * r * 1 / 100.0;

amt = amt + i2;

System.out.println("Interest for the second year: " + i2);

double i3 = amt * r * 1 / 100.0;

amt = amt + i3;

System.out.println("Interest for the third year: " + i3);

}

}

Similar questions