Music, asked by aram11raja21, 4 months ago

Write a C Program to find the smallest of three given numbers. Give the output

also.​

Answers

Answered by DumAssAmi
0

Given three numbers. The task is to find the smallest among given three numbers.

Examples:

Input: first = 15, second = 16, third = 10

Output: 10

Input: first = 5, second = 3, third = 6

Output: 3

Recommended: Please try your approach on {IDE} first, before moving on to the solution.

Approach:

Check if the first element is smaller than second and third. If yes then print it.

Else if check if the second element is smaller than first and third. If yes then print it.

Else third is the smallest element and print it.

Answered by thanushajacinth
2

Answer:

HOPE THIS HELPS U

PLZ MARK THIS ANSWER AS BRAINLIST ME

Explanation:

Get three numbers num1, num2 and num3 and find the smallest one among num1,num2 and num3.

Sample Input 1:

1 6 2

Sample Output 1:

1

       

#include<stdio.h>

int main()

{

int num1,num2,num3;

printf("Enter three numbers:");

scanf("%d %d %d"&num1,&num2,&num3);

if(num1 < num2 && num1 < num3)

{

 printf("%d is smallest",num1);

}

else if(num2 < num3)

{

 printf("%d is smallest",num2);

}

else

{

 printf("%d is smallest",num3);

}  

return 0;

}

Program Explanation  :

Get three inputs num1, num2 and num3 from user using scanf statements.

Check whether num1 is smaller than num2 and num3 using if statement, if it is true print num1 is smallest using printf statement.

Else, num2 or num3 is smallest.

So check whether num2 is smaller than num3 using elseif statement.

if num2 is greater, then print num2 is smallest using printf statement.

Else, print num3 is smallest using printf statement.

Similar questions