WRITE A JAVA CODE
You take a loan from a friend and need to calculate how much you will owe him after 6 months.
You are going to pay him back 10% of the remaining loan amount each month.
Create a program that takes the loan amount as input, calculates and outputs the remaining amount after 6 months.
Sample Input:
20000
Sample Output:
10628
Here is the monthly payment schedule:
Month 1
Payment: 10% of 20000 = 2000
Remaining amount: 18000
Month 2
Payment: 10% of 18000 = 1800
Remaining amount: 16200
Month 3:
Payment: 10% of 16200 = 1620
Remaining amount: 14580
Month 4:
Payment: 10% of 14580 = 1458
Remaining amount: 13122
Month 5:
Payment: 10% of 13122 = 1313
Remaining amount: 11809
Month 6:
Payment: 10% of 11809 = 1181
Remaining amount: 10628
Answers
Answer:
You take a loan from a friend and need to calculate how much you will owe him after 3 months.
You are going to pay him back 10% of the remaining loan amount each month.
Create a program that takes the loan amount as input, calculates and outputs the remaining amount after 3 months.
Sample Input:
20000
Sample Output:
10628
Here is the monthly payment schedule:
Month 1
Payment: 10% of 20000 = 2000
Remaining amount: 18000
Month 2
Payment: 10% of 18000 = 1800
Remaining amount: 16200
Month 3:
Payment: 10% of 16200 = 1620
Remaining amount: 14580
Explanation:
import java.util.Scanner;
public class sakshath{
public static void main(String[]args){
int month=3;
double due;
Scanner scan = new Scanner(System.in);
double loanamount= scan.nextInt();
while(month<6){
due=(0.1*loanamount);
loanamount=loanamount-due;
month++;
}
int loanamounts=(int)loanamount;//dont forgot this... conversion
System.out.println(loanamounts);
}
}