Computer Science, asked by nandioindrila8, 10 months ago

Write a program in Java to accept a sentence in lower case. Convert
first letter of each word of the sentence in upper case. Display the new
sentence so formed.
Sample Input: we are in cyber world
Sample Output: We Are In Cyber World
(ICSE 2018)​

Answers

Answered by amangill1999ag
1

Answer:

// Java program to convert first character

// uppercase in a sentence

class GFG {

static String convert(String str)

{

// Create a char array of given String

char ch[] = str.toCharArray();

for (int i = 0; i < str.length(); i++) {

// If first character of a word is found

if (i == 0 && ch[i] != ' ' ||

ch[i] != ' ' && ch[i - 1] == ' ') {

// If it is in lower-case

if (ch[i] >= 'a' && ch[i] <= 'z') {

// Convert into Upper-case

ch[i] = (char)(ch[i] - 'a' + 'A');

}

}

// If apart from first character

// Any one is in Upper-case

else if (ch[i] >= 'A' && ch[i] <= 'Z')

// Convert into Lower-Case

ch[i] = (char)(ch[i] + 'a' - 'A');

}

// Convert the char array to equivalent String

String st = new String(ch);

return st;

}

public static void main(String[] args)

{

String str = "we are in cyber world";

System.out.println(convert(str));

}

}

Answered by KINGSHREYANSH122
3

Answer:

import java.util.*;

class caseconverter

{

   public static void main()

   {

       Scanner sc=new Scanner(System.in);

       String s1=sc.nextLine(); //input

       String s=Character.toUpperCase(s1.charAt(0))+s1.substring(1);

//changing the first letter to upper case

       for (int i=0;i<s.length();i++)

       {

           char ch=s.charAt(i);

           if (Character.isWhitespace(ch))  

           {

               System.out.print(" "+Character.toUpperCase(s.charAt(i+1)));

               i++;

           } //if compiler finds a whitespace the next letter will be capitalised

           else

               System.out.print(ch);

       }

   }

}

PLS MARK ME BRAINLIEST!!!!

Similar questions