WRITE A PROGRAM in Java to accept two no.s from the user and check whether it is a perfect square or not.
Answers
Answered by
1
program is moh maya ka jal hai mat fas isma
premlatadevi665:
Ab mera question hai ki Hmm class ka name Kya rakhe??
Answered by
0
package com.company;
/* Write a program to accept a number and check whether the number is a perfect square or not.
Sample Input=49
Sample Output= A perfect square.
*/
import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner sc = new Scanner (System.in);
System.out.println("Enter a Number:");
double n = sc.nextDouble();
double n2 = Math.sqrt(n);
if (n2%1==0) {
System.out.println("The entered number is a perfect square");
}
else {
System.out.println("The entered number is not a perfect square");
}
}
}
Similar questions