Computer Science, asked by shrutarthadas, 3 months ago

Write a program to accept Principal, Rate, and time. Calculate and display the interest accumulated for the first year, second year, and third-year compound annually.
Sample input: Principal=₹5000 , Rate=10% per annum ,Time=3 year
Sample output: INterest for the first year:₹500
Interest for the second year:₹550
Interest for the third year:₹605

Answers

Answered by sghvvishald11a
2

please Mark as brainliest

Explanation:

import java.io.*;

public class KboatInterest

{

public static void main(String args[]) throws IOException {

InputStreamReader read = new InputStreamReader(System.in);

BufferedReader in = new BufferedReader(read);

System.out.print("Enter Principal: ");

double p = Double.parseDouble(in.readLine());

System.out.print("Enter Rate: ");

double r = Double.parseDouble(in.readLine());

System.out.print("Enter Time: ");

int t = Integer.parseInt(in.readLine());

double i1 = p * r * 1 / 100.0;

double amt = p + i1;

System.out.println("Interest for the first year: " + i1);

double i2 = amt * r * 1 / 100.0;

amt = amt + i2;

System.out.println("Interest for the second year: " + i2);

double i3 = amt * r * 1 / 100.0;

amt = amt + i3;

System.out.println("Interest for the third year: " + i3);

}

}

Similar questions