Computer Science, asked by Anonymous, 5 months ago

Write a python program to enter employee detail from the user (name of employee,
designation and basic salary) and calculate the following: (HRA 10% OF BS, DA 90 % OF BS ,
TA 08% OF BS , CA 07 % OF BS, LIC 15% OF BS , PF 12% OF BS ) Gross Salary , Net
Salary and Annual Salary and calculate income tax by using the following format:


1 to 100000 = 0%
100000 to 200000 = 10%
200000 to 300000 = 15%
300000 to 400000 = 20%
>400000 = 25%

Answers

Answered by puneetdevman
2

Answer:

Hint given here

Explanation:

Python program to get employee wages and number of days worked from user and find Basic Pay, DA, HRA, PF and Net Pay.

(Note HRA, DA and PF are 10%,5%and 12% of basicpay respectively.)

Sample Input 1: 300 30

Sample Output 1:

Basic Pay:3000 DA 150 HRA:300 PF:360 Net Pay: 3090

days=float(input("Enter No Days Present:"))

wages=float(input("Enter wages per Day:"))

basic=wages*days;

HRA=basic*0.1;

DA=basic*0.05;

PF=basic*0.12;  

netsalary=basic+HRA+DA-PF;

print("\nBasic:%lf \nHRA:%lf \nDA:%lf \nPF:%lf \nNet Salary:%lf" %(basic,HRA,DA,PF,netsalary));

 

get wages and number of days present of an employee using input() method.

calculate basic pay, DA, HRA , PF Net Pay using formula

You can use this logic and implement your calculation percentages in the above code. i have used decimals format for the same calculations.

Similar questions