Computer Science, asked by NoobHarshit, 10 hours ago

1. Write a program to input three angles of a triangle and check whether its construction is possible or not. If possible then check and display whether it is an acute-angled triangle, right-angled or an obtuse-angled triangle. Otherwise, display A Triangle is not possible'. Sample Input: Enter three angles: 40, 50, 90 Sample Output: Right-Angled Triangle. ​

Answers

Answered by tarunntech2006
10

Answer:

import java.util.Scanner;

public class KboatTriangleAngle

{

  public static void main(String args[]) {

      Scanner in = new Scanner(System.in);

      System.out.print("Enter first angle: ");

      int a1 = in.nextInt();

      System.out.print("Enter second angle: ");

      int a2 = in.nextInt();

      System.out.print("Enter third angle: ");

      int a3 = in.nextInt();

      int angleSum = a1 + a2 + a3;

     

      if (angleSum == 180 && a1 > 0 && a2 > 0 && a3 > 0) {

          if (a1 < 90 && a2 < 90 && a3 < 90) {

              System.out.println("Acute-angled Triangle");

          }

          else if (a1 == 90 || a2 == 90 || a3 == 90) {

              System.out.println("Right-angled Triangle");

          }

          else {

              System.out.println("Obtuse-angled Triangle");

          }

      }

      else {

          System.out.println("Triangle not possible");

      }

  }

}

Explanation:

Similar questions